PostgreSQL 9.0 < 9.0.13 / 9.1 < 9.1.9 / 9.2 < 9.2.4 File Deletion

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by a file deletion
vulnerability.

Description :

The version of PostgreSQL installed on the remote host is 9.0.x prior
to 9.0.13, 9.1.x prior to 9.1.9 or 9.2.x prior to 9.2.4. As such, it is
potentially affected by a file deletion vulnerability. A remote,
unauthenticated attacker, could damage or destroy files within a
server's data directory by requesting a database name that begins
with '-'.

See also :

http://www.postgresql.org/about/news/1456/
http://www.postgresql.org/docs/9.0/static/release-9-0-13.html
http://www.postgresql.org/docs/9.1/static/release-9-1-9.html
http://www.postgresql.org/docs/9.2/static/release-9-2-4.html
http://www.vmware.com/security/advisories/VMSA-2013-0005.html

Solution :

Upgrade to PostgreSQL 9.0.13 / 9.1.9 / 9.2.4 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 65855 ()

Bugtraq ID: 58876

CVE ID: CVE-2013-1899