PostgreSQL 8.4 < 8.4.17 / 9.0 < 9.0.13 / 9.1 < 9.1.9 / 9.2 < 9.2.4 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of PostgreSQL installed on the remote host is 8.4.x prior
to 8.4.17, 9.0.x prior to 9.0.13, 9.1.x prior to 9.1.9, or 9.2.x prior
to 9.2.4. It therefore is potentially affected by multiple
vulnerabilities :

- Enterprise DB's installers for Linux and Mac OS X create
a directory and file in '/tmp' with predictable names.
(CVE-2013-1902)

- Enterprise DB's installers for Linux and Mac OS X pass
the database superuser password to a script in an
insecure fashion. (CVE-2013-1903)

See also :

http://www.postgresql.org/about/news/1456/
http://www.postgresql.org/docs/8.4/static/release-8-4-17.html
http://www.postgresql.org/docs/9.0/static/release-9-0-13.html
http://www.postgresql.org/docs/9.1/static/release-9-1-9.html
http://www.postgresql.org/docs/9.2/static/release-9-2-4.html

Solution :

Upgrade to PostgreSQL 8.4.17 / 9.0.13 / 9.1.9 / 9.2.4 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 65854 ()

Bugtraq ID: 58877
58882

CVE ID: CVE-2013-1902
CVE-2013-1903