MariaDB 5.5 < 5.5.30 Multiple Vulnerabilities

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote database server has multiple vulnerabilities.

Description :

The version of MariaDB 5.5 installed on the remote host is earlier than
5.5.30 and is, therefore, potentially affected by vulnerabilities in the
following components :

- GIS
- yaSSL

See also :

http://www.zerodayinitiative.com/advisories/ZDI-13-251/
https://kb.askmonty.org/en/mariadb-5530-release-notes/
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-30.html
https://mariadb.atlassian.net/browse/MDEV-4252

Solution :

Upgrade to MariaDB 5.5.30 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 65732 ()

Bugtraq ID: 58511
58595

CVE ID: CVE-2013-1492
CVE-2013-1861