Mac OS X : Apple Safari < 6.0.3 Multiple Vulnerabilities

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.

Synopsis :

The remote host contains a web browser that is affected by several

Description :

The version of Apple Safari installed on the remote Mac OS X 10.7 or
10.8 host is earlier than 6.0.3. It is, therefore, potentially
affected by several issues :

- Multiple memory corruption vulnerabilities exist in
WebKit that could lead to unexpected program termination
or arbitrary code execution. (CVE-2012-2824 /
CVE-2012-2857 / CVE-2013-0948 / CVE-2013-0949 /
CVE-2013-0950 / CVE-2013-0951 / CVE-2013-0952 /
CVE-2013-0953 / CVE-2013-0954 / CVE-2013-0955 /
CVE-2013-0956 / CVE-2013-0958 / CVE-2013-0959 /
CVE-2013-0960 / CVE-2013-0961)

- A cross-site scripting issue exists in WebKit's handling
of frame elements. (CVE-2012-2889)

- A cross-site scripting issue exists in WebKit's handling
of content pasted from a different origin.

See also :

Solution :

Upgrade to Apple Safari 6.0.3 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.9
Public Exploit Available : false

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial