MariaDB 5.3 < 5.3.12 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MariaDB 5.3 installed on the remote host is earlier
than 5.3.12 and is, therefore, potentially affected by vulnerabilities
in the following components :

- Information Schema
- InnoDB
- Server
- Server Locking
- Server Optimizer
- Server Privileges
- Server Replication

See also :

https://kb.askmonty.org/en/mariadb-5312-release-notes/
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-67.html

Solution :

Upgrade to MariaDB 5.3.12 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 7.0
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true