Apache 2.4 < 2.4.4 Multiple XSS Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by multiple cross-site scripting
vulnerabilities.

Description :

According to its banner, the version of Apache 2.4 installed on the
remote host is earlier than 2.4.4. It is, therefore, potentially
affected by the following cross-site scripting vulnerabilities :

- Errors exist related to the modules mod_info,
mod_status, mod_imagemap, mod_ldap, and mod_proxy_ftp
and unescaped hostnames and URIs that could allow cross-
site scripting attacks. (CVE-2012-3499)

- An error exists related to the mod_proxy_balancer
module's manager interface that could allow cross-site
scripting attacks. (CVE-2012-4558)

Note that Nessus did not actually test for these issues, but instead
has relied on the version in the server's banner.

See also :

http://www.apache.org/dist/httpd/CHANGES_2.4.4
http://httpd.apache.org/security/vulnerabilities_24.html

Solution :

Either ensure that the affected modules are not in use or upgrade to
Apache version 2.4.4 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 64893 ()

Bugtraq ID: 58165

CVE ID: CVE-2012-3499
CVE-2012-4558