Oracle Java SE Multiple Vulnerabilities (February 2011 CPU) (Unix)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Unix host contains a programming platform that is affected
by multiple vulnerabilities.

Description :

The version of Oracle (formerly Sun) Java SE or Java for Business
installed on the remote host is earlier than 6 Update 24 / 5.0 Update 28
/ 1.4.2_30. Such versions are potentially affected by security issues
in the following components :

- Deployment
- HotSpot
- Install
- JAXP
- Java Language
- JDBC
- Launcher
- Networking
- Security
- Sound
- Swing
- XML Digital Signature
- 2D

See also :

http://www.zerodayinitiative.com/advisories/ZDI-11-082
http://www.zerodayinitiative.com/advisories/ZDI-11-083
http://www.zerodayinitiative.com/advisories/ZDI-11-084
http://www.zerodayinitiative.com/advisories/ZDI-11-085
http://www.zerodayinitiative.com/advisories/ZDI-11-086
http://www.nessus.org/u?7d6610d2
http://www.oracle.com/technetwork/java/eol-135779.html

Solution :

Update to JDK / JRE 6 Update 24, JDK 5.0 Update 28, SDK 1.4.2_30 or
later and remove, if necessary, any affected versions.

Note that an Extended Support contract with Oracle is needed to obtain
JDK 5.0 Update 28 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.8
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true