Oracle Java JDK / JRE 6 < Update 30 Multiple Vulnerabilities (Unix)

This script is Copyright (C) 2013-2015 Tenable Network Security, Inc.

Synopsis :

The remote host contains a runtime environment that is affected by
multiple vulnerabilities.

Description :

The version of Oracle (formerly Sun) Java Runtime Environment (JRE) 6.x
installed on the remote host is earlier than Update 30 and is,
therefore, potentially affected by the following vulnerabilities:

- A stack overflow error exists related to proxy
tunnels. (Bug #6670868)

- An error exists related to foreach loops containing
generics that can lead to javac crashes. (Bug #6682380)

- An error exists related to security exceptions in
(Bug #6761678)

- An error in 'URI.equals' can allow a return value of
'true' when handling escaped octets. (Bug #7041800)

- An error related to 'liveconnect' can cause secure
cookies not to be transferred. (Bug #7102914)

- SSL connectivity is broken when using the cipher suite
TLS_DH_anon_WITH_AES_128_CBC_SHA. (Bug #7103725)

See also :

Solution :

Update to JDK / JRE 6 Update 30 or later and remove, if necessary,
any affected versions.

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 7.4

Family: Misc.

Nessus Plugin ID: 64838 ()

Bugtraq ID: