Oracle Java JDK / JRE 6 < Update 20 Multiple Vulnerabilities (Unix)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote host contains a runtime environment that is affected by
multiple vulnerabilities.

Description :

The version of Oracle (formerly Sun) Java Runtime Environment (JRE)
installed on the remote host is earlier than 6 Update 20. Such versions
are potentially missing critical security updates.

As a result, the remote host could be affected by multiple
vulnerabilities.

See also :

http://www.nessus.org/u?559335b7
http://www.oracle.com/technetwork/java/javase/6u20-142805.html

Solution :

Update to JDK / JRE 6 Update 20 or later and remove if necessary any
affected versions.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 64837 ()

Bugtraq ID: 39346
39492

CVE ID: CVE-2010-0886
CVE-2010-0887
CVE-2010-1423