Flash Player for Mac <= 10.3.183.51 / 11.5.502.149 Multiple Vulnerabilities (APSB13-05)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on the
remote Mac OS X host is 11.x equal or prior to 11.5.502.149, or 10.x
equal or prior to 10.3.183.51. It is, therefore, potentially affected
by the following vulnerabilities :

- Several unspecified issues exist that could lead to
buffer overflows and arbitrary code execution.
(CVE-2013-1372, CVE-2013-0645, CVE-2013-1373,
CVE-2013-1369, CVE-2013-1370, CVE-2013-1366,
CVE-2013-1365, CVE-2013-1368, CVE-2013-0642,
CVE-2013-1367)

- Several unspecified use-after-free vulnerabilities
exist that could lead to remote code execution.
(CVE-2013-0649, CVE-2013-1374, CVE-2013-0644)

- Two unspecified issues exists that could lead to
memory corruption and arbitrary code execution.
(CVE-2013-0638, CVE-2013-0647)

- An unspecified information disclosure vulnerability exists.
(CVE-2013-0637)

- An unspecified integer overflow vulnerability exists.
(CVE-2013-0639)

See also :

http://www.adobe.com/support/security/bulletins/apsb13-05.html

Solution :

Upgrade to Adobe Flash Player version 10.3.183.61 / 11.6.602.167 or
later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false