Adobe AIR for Mac 3.x <= 3.5.0.1060 Multiple Vulnerabilities (APSB13-05)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the instance of Adobe AIR 3.x on the remote
Mac OS X host is 3.5.0.1060 or earlier. It is, therefore, reportedly
affected by multiple vulnerabilities :

- Several unspecified issues exist that could lead to
buffer overflows and arbitrary code execution.
(CVE-2013-1372, CVE-2013-0645, CVE-2013-1373,
CVE-2013-1369, CVE-2013-1370, CVE-2013-1366,
CVE-2013-1365, CVE-2013-1368, CVE-2013-0642,
CVE-2013-1367)

- Several unspecified use-after-free vulnerabilities exist
that could lead to remote code execution. (CVE-2013-0649,
CVE-2013-1374, CVE-2013-0644)

- Two unspecified issues exist that could lead to memory
corruption and arbitrary code execution. (CVE-2013-0638,
CVE-2013-0647)

- An unspecified information disclosure vulnerability
exists. (CVE-2013-0637)

- An unspecified integer overflow vulnerability exists.
(CVE-2013-0639)

See also :

http://www.adobe.com/support/security/bulletins/apsb13-05.html

Solution :

Upgrade to Adobe AIR 3.6.0.597 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false