Mac OS X : OS X Server < 2.2.1 Multiple Vulnerabilities

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote host is missing an update for OS X Server that fixes two
security issues.

Description :

The remote Mac OS X 10.8 host has a version of OS X Server that is
older than version 2.2.1. As such, it is reportedly affected by the
following vulnerabilities :

- A type casting issue in Ruby on Rails' handling of XML
parameters could allow an attacker to execute arbitrary
code through either Profile Manager or Wiki Server.
(CVE-2013-0156)

- A type casting issue in Ruby on Rails' handling of JSON
data could allow an attacker to execute arbitrary
code through Wiki Server. (CVE-2013-0333)

See also :

http://support.apple.com/kb/HT5644
http://lists.apple.com/archives/security-announce/2013/Feb/msg00001.html
http://www.securityfocus.com/archive/1/525572/30/0/threaded

Solution :

Upgrade to Mac OS X Server v2.2.1 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 64476 ()

Bugtraq ID: 57187
57575

CVE ID: CVE-2013-0156
CVE-2013-0333