Portable SDK for UPnP Devices (libupnp) < 1.6.18 Multiple Stack-based Buffer Overflows

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

A network service running on the remote host has multiple buffer
overflow vulnerabilities.

Description :

According to its banner, the version of Portable SDK for UPnP Devices
(libupnp) running on the remote host is older than 1.6.18, and
therefore, has multiple stack-based buffer overflow vulnerabilities. A
remote, unauthenticated attacker could exploit any of these
vulnerabilities to execute arbitrary code. Many applications that use
this library execute the vulnerable code as root.

See also :

http://www.nessus.org/u?37da582a
https://community.rapid7.com/docs/DOC-2150
http://www.nessus.org/u?ef4b795d
http://www.nessus.org/u?698e06b3

Solution :

Upgrade to libupnp 1.6.18 or later. If libupnp is used as a third
party library by a different application, contact the vendor of that
application for a fix.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Gain a shell remotely

Nessus Plugin ID: 64394 ()

Bugtraq ID: 57602

CVE ID: CVE-2012-5958
CVE-2012-5959
CVE-2012-5960
CVE-2012-5961
CVE-2012-5962
CVE-2012-5963
CVE-2012-5964
CVE-2012-5965