RHEL 5 : flash-plugin (RHSA-2009:1657)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

An updated Adobe Flash Player package that fixes multiple security
issues is now available for Red Hat Enterprise Linux 5 Supplementary.

This update has been rated as having critical security impact by the
Red Hat Security Response Team.

The flash-plugin package contains a Mozilla Firefox compatible Adobe
Flash Player web browser plug-in.

Multiple security flaws were found in the way Flash Player displayed
certain SWF content. An attacker could use these flaws to create a
specially-crafted SWF file that would cause flash-plugin to crash or,
possibly, execute arbitrary code when the victim loaded a page
containing the specially-crafted SWF content. (CVE-2009-3794,
CVE-2009-3796, CVE-2009-3797, CVE-2009-3798, CVE-2009-3799,
CVE-2009-3800)

All users of Adobe Flash Player should install this updated package,
which upgrades Flash Player to version 10.0.42.34.

See also :

https://www.redhat.com/security/data/cve/CVE-2009-3794.html
https://www.redhat.com/security/data/cve/CVE-2009-3796.html
https://www.redhat.com/security/data/cve/CVE-2009-3797.html
https://www.redhat.com/security/data/cve/CVE-2009-3798.html
https://www.redhat.com/security/data/cve/CVE-2009-3799.html
https://www.redhat.com/security/data/cve/CVE-2009-3800.html
http://www.adobe.com/support/security/bulletins/apsb09-19.html
http://rhn.redhat.com/errata/RHSA-2009-1657.html

Solution :

Update the affected flash-plugin package.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 63907 ()

Bugtraq ID:

CVE ID: CVE-2009-3794
CVE-2009-3796
CVE-2009-3797
CVE-2009-3798
CVE-2009-3799
CVE-2009-3800