RHEL 4 : Adobe Acrobat Reader (RHSA-2007:0017)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated acroread packages that fix several security issues are now
available for Red Hat Enterprise Linux 4.

This update has been rated as having critical security impact by the
Red Hat Security Response Team.

The Adobe Acrobat Reader allows users to view and print documents in
portable document format (PDF).

A cross site scripting flaw was found in the way the Adobe Reader
Plugin processes certain malformed URLs. A malicious web page could
inject arbitrary javascript into the browser session which could
possibly lead to a cross site scripting attack. (CVE-2007-0045)

Two arbitrary code execution flaws were found in the way Adobe Reader
processes malformed document files. It may be possible to execute
arbitrary code on a victim's machine if the victim opens a malicious
PDF file. (CVE-2006-5857, CVE-2007-0046)

All users of Acrobat Reader are advised to upgrade to these updated
packages, which contain Acrobat Reader version 7.0.9 and are not
vulnerable to these issues.

See also :

https://www.redhat.com/security/data/cve/CVE-2006-5857.html
https://www.redhat.com/security/data/cve/CVE-2007-0045.html
https://www.redhat.com/security/data/cve/CVE-2007-0046.html
http://www.adobe.com/support/security/bulletins/apsb07-01.html
http://rhn.redhat.com/errata/RHSA-2007-0017.html

Solution :

Update the affected acroread and / or acroread-plugin packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Family: Red Hat Local Security Checks

Nessus Plugin ID: 63835 ()

Bugtraq ID:

CVE ID: CVE-2006-5857
CVE-2007-0045
CVE-2007-0046