MySQL 5.1 < 5.1.67 Multiple Vulnerabilities

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL 5.1 installed on the remote host is earlier than
5.1.67 and is, therefore, affected by vulnerabilities in the following
components :

- Information Schema
- InnoDB
- Server
- Server Locking
- Server Optimizer
- Server Privileges
- Server Replication

See also :

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-67.html
http://www.nessus.org/u?405581e3

Solution :

Upgrade to MySQL version 5.1.67 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true