Samba 4.x < 4.0.1 AD DC LDAP Directory Objects Security Bypass

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is affected by a security bypass
vulnerability.

Description :

According to its banner, the version of Samba 4.x running on the remote
host is earlier than 4.0.1, and is, therefore, potentially affected by a
security bypass vulnerability.

When acting as an Active Directory (AD) Domain Controller (DC), the
application can improperly grant write access to an LDAP directory
object or its attributes improperly. This error can be triggered when a
user or group is granted any access to an LDAP directory object based on
objectClass or is granted write access to any attribute on the object.

Note that, by default, the application does not make 'authenticated
users' a part of the 'pre-windows 2000 compatible access' group, which
is the group that typically receives the problematic per-objectClass
permission.

Further note that Nessus has not actually tried to exploit this issue or
otherwise determine if the patch or workaround has been applied.

See also :

http://www.samba.org/samba/security/CVE-2013-0172
http://www.samba.org/samba/history/samba-4.0.1.html
http://www.nessus.org/u?24a2ba59

Solution :

Either install the patch referenced in the project's advisory or
upgrade to 4.0.1 or later.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 2.6
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 63561 ()

Bugtraq ID: 57329

CVE ID: CVE-2013-0172