Cerberus FTP Server < 5.0.6.0 Multiple XSS

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The FTP server installed on the remote Windows host has multiple
cross-site scripting vulnerabilities.

Description :

The version of Cerberus FTP server on the remote host is earlier than
5.0.6.0. As such, it is potentially affected by the following cross-
site scripting vulnerabilities :

- The user-supplied input for fields under administration
'Messages' tab are not validated before being returned
to the user. (OSVDB 88370)

- The user-supplied input to the 'USER' FTP command is
not validated before display in the administration
logging page. (OSVDB 88495)

A remote attacker could exploit these by tricking a user into requesting
a maliciously crafted URL, resulting in the execution of arbitrary
script code.

See also :

http://cerberusftp.com/releasenotes.html
http://www.nessus.org/u?f90a2068

Solution :

Upgrade to Cerberus FTP server 5.0.6.0 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: FTP

Nessus Plugin ID: 63560 ()

Bugtraq ID: 56906

CVE ID: CVE-2012-6339