PostgreSQL 8.4 < 8.4.11 / 9.0 < 9.0.7 / 9.1 < 9.1.3 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of PostgreSQL installed on the remote host is 8.4.x prior
to 8.4.11, 9.0.x prior to 9.0.7, or 9.1.x prior to 9.1.3. It is,
therefore, potentially affected by multiple vulnerabilities :

- Permissions on a function called by a trigger are not
properly checked. (CVE-2012-0866)

- SSL certificate name checks are truncated to 32
characters, allowing connection spoofing under some
circumstances when using third-party certificate
authorities. (CVE-2012-0867)

- Line breaks in object names can be exploited to execute
arbitrary SQL commands when reloading a pg_dump file.

See also :

Solution :

Upgrade to PostgreSQL 8.3.19 / 8.4.12 / 9.0.8 / 9.1.4 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.0
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 63352 ()

Bugtraq ID: 52188

CVE ID: CVE-2012-0866

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial