PostgreSQL 8.2 < 8.2.20 / 8.3 < 8.3.14 / 8.4 < 8.4.7 / 9.0 < 9.0.3 Buffer Overflow Vulnerability

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by a buffer overflow
vulnerability.

Description :

The version of PostgreSQL installed on the remote host is 8.2.x prior
to 8.2.20, 8.3.x prior to 8.3.14, 8.4.x prior to 8.4.7, or 9.0.x prior
to 9.0.3. It therefore is potentially affected by a buffer overflow
vulnerability.

By calling functions from the intarray optional module with certain
parameters, a remote, authenticated attacker could execute arbitrary
code on the remote host subject to the privileges of the user running
the affected application.

See also :

http://www.postgresql.org/about/news/1289/
http://www.postgresql.org/docs/8.2/static/release-8-2-20.html
http://www.postgresql.org/docs/8.3/static/release-8-3-14.html
http://www.postgresql.org/docs/8.4/static/release-8-4-7.html
http://www.postgresql.org/docs/9.0/static/release-9-0-3.html

Solution :

Upgrade to PostgreSQL 8.2.20 / 8.3.14 / 8.4.7 / 9.0.3 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 4.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 63351 ()

Bugtraq ID: 46084

CVE ID: CVE-2010-4015