This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.
The remote database server is affected by a buffer overflow
The version of PostgreSQL installed on the remote host is 8.2.x prior
to 8.2.20, 8.3.x prior to 8.3.14, 8.4.x prior to 8.4.7, or 9.0.x prior
to 9.0.3. It therefore is potentially affected by a buffer overflow
By calling functions from the intarray optional module with certain
parameters, a remote, authenticated attacker could execute arbitrary
code on the remote host subject to the privileges of the user running
the affected application.
See also :
Upgrade to PostgreSQL 8.2.20 / 8.3.14 / 8.4.7 / 9.0.3 or later.
Risk factor :
Medium / CVSS Base Score : 6.5
CVSS Temporal Score : 4.8
Public Exploit Available : false