PostgreSQL 7.4 < 7.4.30 / 8.0 < 8.0.26 / 8.1 < 8.1.22 / 8.2 < 8.2.18 / 8.3 < 8.3.12 / 8.4 < 8.4.5 / 9.0 < 9.0.1

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by a privilege escalation
vulnerability.

Description :

The version of PostgreSQL installed on the remote host is 7.4 prior to
7.4.30, 8.0 prior to 8.0.26, 8.1 prior to 8.1.22, 8.2 prior to 8.2.18,
8.3 prior to 8.3.12, 8.4 prior to 8.4.5, or 9.0 prior to 9.0.1. It
therefore is potentially affected by a privilege escalation
vulnerability.

A remote, authenticated attacker could elevate privileges via
specially crafted code in a SECURITY DEFINER function.

See also :

http://www.postgresql.org/about/news/1244/
http://www.postgresql.org/docs/7.4/static/release.html#RELEASE-7-4-30
http://www.postgresql.org/docs/8.0/static/release.html#RELEASE-8-0-26
http://www.postgresql.org/docs/8.1/static/release-8-1-22.html
http://www.postgresql.org/docs/8.2/static/release-8-2-18.html
http://www.postgresql.org/docs/8.3/static/release-8-3-12.html
http://www.postgresql.org/docs/8.4/static/release-8-4-5.html
http://www.postgresql.org/docs/9.0/static/release.html#RELEASE-9-0-1

Solution :

Upgrade to PostgreSQL 7.4.30 / 8.0.26 / 8.1.22 / 8.2.18 / 8.3.12 /
8.4.5 / 9.0.1 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 4.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 63350 ()

Bugtraq ID: 43747

CVE ID: CVE-2010-3433