PostgreSQL 7.4 < 7.4.29 / 8.0 < 8.0.25 / 8.1 < 8.1.21 / 8.2 < 8.2.17 / 8.3 < 8.3.11 / 8.4 < 8.4.4 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of PostgreSQL installed on the remote host is 7.4 prior to
7.4.29, 8.0 prior to 8.0.25, 8.1 prior to 8.1.21, 8.2 prior to 8.2.17,
8.3 prior to 8.3.11 or 8.4 prior to 8.4.4. As such, it is potentially
affected by multiple vulnerabilities :

- A vulnerability in Safe.pm and PL/Perl can allow an
authenticated user to run arbitrary Perl code on the
database server if PL/Perl is installed and enabled.
(CVE-2010-1169)

- Insecure permissions on the pltcl_modules table could
allow an authenticated user to run arbitrary Tcl code
on the database server if PL/Tcl is installed and
enabled. (CVE-2010-1170)

- An unprivileged database user can remove superuser-only
settings that were applied to the user's account with
ALTER USER by a superuser thus bypassing settings that
should be enforced. (CVE-2010-1975)

See also :

http://www.postgresql.org/about/news/1203/
http://www.postgresql.org/docs/7.4/static/release-7-4-29.html
http://www.postgresql.org/docs/8.0/static/release-8-0-25.html
http://www.postgresql.org/docs/8.1/static/release-8-1-21.html
http://www.postgresql.org/docs/8.2/static/release-8-2-17.html
http://www.postgresql.org/docs/8.3/static/release-8-3-11.html
http://www.postgresql.org/docs/8.4/static/release-8-4-4.html

Solution :

Upgrade to PostgreSQL 7.4.29 / 8.0.25 / 8.1.21 / 8.2.17 / 8.3.11 /
8.4.4 or later.

Risk factor :

High / CVSS Base Score : 8.5
(CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.3
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 63349 ()

Bugtraq ID: 40215
40304

CVE ID: CVE-2010-1169
CVE-2010-1170
CVE-2010-1975