This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.
The remote database server is affected by multiple vulnerabilities.
The version of PostgreSQL installed on the remote host is 7.4 prior to
7.4.29, 8.0 prior to 8.0.25, 8.1 prior to 8.1.21, 8.2 prior to 8.2.17,
8.3 prior to 8.3.11 or 8.4 prior to 8.4.4. As such, it is potentially
affected by multiple vulnerabilities :
- A vulnerability in Safe.pm and PL/Perl can allow an
authenticated user to run arbitrary Perl code on the
database server if PL/Perl is installed and enabled.
- Insecure permissions on the pltcl_modules table could
allow an authenticated user to run arbitrary Tcl code
on the database server if PL/Tcl is installed and
- An unprivileged database user can remove superuser-only
settings that were applied to the user's account with
ALTER USER by a superuser thus bypassing settings that
should be enforced. (CVE-2010-1975)
See also :
Upgrade to PostgreSQL 7.4.29 / 8.0.25 / 8.1.21 / 8.2.17 / 8.3.11 /
8.4.4 or later.
Risk factor :
High / CVSS Base Score : 8.5
CVSS Temporal Score : 6.3
Public Exploit Available : false