Adobe AIR for Mac 3.x <= 3.5.0.600 Multiple Vulnerabilities (APSB12-27)

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the instance of Adobe AIR 3.x on the
remote Mac OS X host is 3.5.0.600 or earlier. It is, therefore,
reportedly affected by multiple vulnerabilities :

- An unspecified error exists that can allow a buffer
overflow and arbitrary code execution. (CVE-2012-5676)

- An unspecified error exists that can allow an integer
overflow and arbitrary code execution. (CVE-2012-5677)

- An unspecified error exists that can lead to memory
corruption and arbitrary code execution. (CVE-2012-5678)

See also :

http://www.zerodayinitiative.com/advisories/ZDI-13-021/
http://www.adobe.com/support/security/bulletins/apsb12-27.html

Solution :

Upgrade to Adobe AIR 3.5.0.890 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 63243 ()

Bugtraq ID: 56892
56896
56898

CVE ID: CVE-2012-5676
CVE-2012-5677
CVE-2012-5678