NetIQ Privileged User Manager ldapagnt_eval() Function Remote Code Execution (version check)

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has a web application that is affected by a remote code
execution vulnerability.

Description :

According to the self-reported version of the NetIQ Privileged User
Manager 'ldapagnt' package installed on the remote host, the server
contains a flaw that is triggered when an error occurs in the
'ldapagnt_eval()' function when parsing requests. An unauthenticated
attacker could exploit this flaw to execute arbitrary code with SYSTEM
privileges.

Note that Nessus did not check for the presence of a workaround.

See also :

http://retrogod.altervista.org/9sg_novell_netiq_ldapagnt_adv.htm
https://www.novell.com/support/kb/doc.php?id=7011385

Solution :

Apply NetIQ Privileged User Manager 2.3.1 HF2 (2.3.1-2) or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: CGI abuses

Nessus Plugin ID: 63185 ()

Bugtraq ID: 56539

CVE ID: CVE-2012-5932

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now