MariaDB 5.5 < 5.5.28a Buffer Overflow

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by a buffer overflow
vulnerability.

Description :

The version of MariaDB 5.5 running on the remote host is prior to
5.5.28a. It is, therefore, affected by a buffer overflow
vulnerability. A remote, authenticated attacker can exploit this to
execute arbitrary code.

See also :

http://seclists.org/fulldisclosure/2012/Dec/4
https://kb.askmonty.org/en/mariadb-5528a-release-notes/

Solution :

Upgrade to MariaDB version 5.5.28a or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.1
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 63150 ()

Bugtraq ID: 56769

CVE ID: CVE-2012-5611

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now