MariaDB 5.3 < 5.3.11 Buffer Overflow

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server has a buffer overflow vulnerability.

Description :

The version of MariaDB 5.3 installed on the remote host is earlier than
5.3.11 and is, therefore, affected by a buffer overflow vulnerability.
A remote, authenticated attacker could exploit this to execute arbitrary
code.

See also :

http://archives.neohapsis.com/archives/fulldisclosure/2012-12/0005.html
https://kb.askmonty.org/en/mariadb-5311-release-notes/

Solution :

Upgrade to MariaDB 5.3.11 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 63149 ()

Bugtraq ID: 56769

CVE ID: CVE-2012-5611