Wordfence Plugin for WordPress 'email' Parameter XSS

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote web server hosts a PHP script that is affected by a cross-
site scripting vulnerability.

Description :

The version of the Wordfence plugin for WordPress installed on the
remote host fails to properly sanitize user-supplied input to the
'email' parameter in the lib/wordfenceClass.php script. An
unauthenticated, remote attacker can exploit this issue, via a
specially crafted request, to execute arbitrary script code in a
user's browser session.

See also :

http://seclists.org/fulldisclosure/2012/Oct/139
https://www.wordfence.com/

Solution :

Upgrade to Wordfence Plugin version 3.3.7 or later

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 63064 ()

Bugtraq ID: 56159

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now