IrfanView < 4.35 Multiple Heap-Based Buffer Overflows

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

A graphic viewer installed on the remote host is affected by multiple
buffer overflow vulnerabilities.

Description :

The remote Windows host contains a version of IrfanView prior to
version 4.35. It is, therefore, reportedly affected by the following
vulnerabilities :

- An error exists related to 'ImageWidth' value handling
in JPEG compressed TIFF images.

- An error exists related to 'End of Line' marker handling
in RLE compressed BMP images.

These vulnerabilities could allow heap-based buffer overflows, which
could lead to arbitrary code execution.

See also :

http://www.irfanview.com/main_history.htm
http://www.irfanview.com/history_old.htm
http://www.nessus.org/u?8ffbdf43
http://www.nessus.org/u?bb817723

Solution :

Upgrade to IrfanView version 4.35 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 63059 ()

Bugtraq ID: 47338

CVE ID: CVE-2009-5022

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now