Apache Tomcat 7.0.x < 7.0.30 Multiple Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat service may be affected by multiple

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.0 listening on the remote host is earlier than Tomcat 7.0.30
and, therefore, may be affected by the following vulnerabilities :

- An error related to chunked transfer encoding and
extensions could allow limited denial of service
attacks. (CVE-2012-3544)

- An error exists related to FORM authentication that can
allow security bypass if 'j_security_check' is appended
to the request. (CVE-2012-3546)

- Replay-countermeasure functionality in HTTP Digest
Access Authentication tracks cnonce values instead of
nonce values, which makes it easier for attackers to
bypass access restrictions by sniffing the network for
valid requests. (CVE-2012-5885)

- HTTP Digest Access Authentication implementation caches
information about the authenticated user, which could
potentially allow an attacker to bypass authentication
via session ID. (CVE-2012-5886)

- HTTP Digest Access Authentication implementation does
not properly check for stale nonce values with
enforcement of proper credentials, which allows an
attacker to bypass restrictions by sniffing requests.

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so these may be
false positives.

See also :


Solution :

Update Apache Tomcat to version 7.0.30 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 62988 ()

Bugtraq ID: 56403

CVE ID: CVE-2012-3544