Apache Tomcat 5.5.x < 5.5.36 DIGEST Authentication Multiple Security Weaknesses

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat service may be affected by multiple security
weaknesses.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 5.5 listening on the remote host is earlier than Tomcat 5.5.36
and, therefore, may be affected by the following vulnerabilities :

- Replay-countermeasure functionality in HTTP Digest
Access Authentication tracks cnonce values instead of
nonce values, which makes it easier for attackers to
bypass access restrictions by sniffing the network for
valid requests. (CVE-2012-5885)

- HTTP Digest Access Authentication implementation caches
information about the authenticated user, which could
potentially allow an attacker to bypass authentication
via session ID. (CVE-2012-5886)

- HTTP Digest Access Authentication implementation does
not properly check for stale nonce values with
enforcement of proper credentials, which allows an
attacker to bypass restrictions by sniffing requests.
(CVE-2012-5887)

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so these may be
false positives.

See also :

http://tomcat.apache.org/security-5.html#Fixed_in_Apache_Tomcat_5.5.36

Solution :

Update Apache Tomcat to version 5.5.36 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 62986 ()

Bugtraq ID: 56403

CVE ID: CVE-2012-5885
CVE-2012-5886
CVE-2012-5887