Apache Tomcat 7.0.x < 7.0.28 Multiple Denial of Service Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat service may be affected by multiple remote
denial of service vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.0 listening on the remote host is earlier than Tomcat 7.0.28
and, therefore, may be affected by the following vulnerabilites :

- A flaw exists within the parseHeaders() function that
could allow for a crafted header to cause a remote
denial of service. (CVE-2012-2733)

- An error exists related to the 'NIO' connector when
HTTPS and 'sendfile' are enabled that can force the
application into an infinite loop. (CVE-2012-4534)

Note that Nessus did not actually test for the flaw but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

See also :


Solution :

Update Apache Tomcat to version 7.0.28 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 62985 ()

Bugtraq ID: 56402

CVE ID: CVE-2012-2733