HP LoadRunner < 11.00 Patch 4 Code Execution (intrusive check)

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a software performance testing application
that is affected by a remote code execution vulnerability.

Description :

The version of HP LoadRunner hosted on the remote Windows host is
potentially affected by a code execution vulnerability. The application
fails to properly handle incoming packets with '0x00000000' as the first
32-bit value. A remote, unauthenticated attacker, exploiting this flaw,
could execute arbitrary code on the remote host subject to the
privileges of the user running the affected application.

This plugin sends crafted packets to the LoadRunner Agent service, which
will crash a vulnerable instance. If it is successful, a manual restart
of the service is necessary.

See also :

http://www.zerodayinitiative.com/advisories/ZDI-12-016/
http://www.securityfocus.com/archive/1/522928/30/0/threaded
http://www.nessus.org/u?b6425436

Solution :

Upgrade to HP LoadRunner 11.00 Patch 4 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Gain a shell remotely

Nessus Plugin ID: 62902 ()

Bugtraq ID: 51398

CVE ID: CVE-2011-4789