Adobe AIR 3.x <= 3.4.0.2710 Multiple Vulnerabilities (APSB12-24)

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the instance of Adobe AIR on the remote
Windows host is 3.4.0.2710 or earlier. It is, therefore, reportedly
affected by multiple vulnerabilities :

- Several unspecified issues exist that can lead to buffer
overflows and arbitrary code execution. (CVE-2012-5274,
CVE-2012-5275, CVE-2012-5276, CVE-2012-5277,
CVE-2012-5280)

- An unspecified security bypass issue exists that can
lead to arbitrary code execution. (CVE-2012-5278)

- An unspecified issue exists that can lead to memory
corruption and arbitrary code execution. (CVE-2012-5279)

See also :

http://www.adobe.com/support/security/bulletins/apsb12-24.html

Solution :

Upgrade to Adobe AIR 3.5.0.600 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false