MySQL 5.1 < 5.1.66 Multiple Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL 5.1 installed on the remote host is earlier than
5.1.66 and is, therefore, affected by vulnerabilities in the following
components :

- Server Installation
- Server
- Server Optimizer
- GIS Extension

See also :

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-66.html
http://www.nessus.org/u?1cef09be
http://www.nessus.org/u?405581e3

Solution :

Upgrade to MySQL version 5.1.66 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C)
CVSS Temporal Score : 5.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 62639 ()

Bugtraq ID: 56003
56005
56027
57411

CVE ID: CVE-2012-3160
CVE-2012-3177
CVE-2012-3180
CVE-2012-5060