MySQL 5.1 < 5.1.65 Multiple Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL 5.1 installed on the remote host is earlier than
5.1.65 and is, therefore, affected by vulnerabilities in the following
components :

- Information Schema
- Protocol
- Server Optimizer
- Server Replication

See also :

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-65.html
http://www.nessus.org/u?1cef09be

Solution :

Upgrade to MySQL version 5.1.65 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 7.8
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 62638 ()

Bugtraq ID: 55990
56017
56036
56021

CVE ID: CVE-2012-3150
CVE-2012-3158
CVE-2012-3163
CVE-2012-3197