Firefox < 10.0.9 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.

Synopsis :

The remote Mac OS X host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The installed version of Firefox is earlier than 10.0.9 and thus, is
potentially affected by the following security issues :

- An unspecified error exists that can allow attackers to
bypass the 'Same Origin Policy' and access the
'Location' object. (CVE-2012-4192)

- An error exists related to 'security wrappers' and the
function 'defaultValue()' that can allow cross-site
scripting attacks. (CVE-2012-4193)

See also :

Solution :

Upgrade to Firefox 10.0.9 ESR or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 62584 ()

Bugtraq ID: 56154

CVE ID: CVE-2012-4192