Flash Player for Mac <= 10.3.183.23 / 11.4.402.265 Multiple Vulnerabilities (APSB12-22)

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on the
remote Mac OS X host is 11.x equal to or earlier than 11.4.402.264, or
10.x equal to or earlier than 10.3.183.23. It is, therefore,
potentially affected by multiple vulnerabilities :

- Several unspecified issues exist that can lead to buffer
overflows and arbitrary code execution. (CVE-2012-5248,
CVE-2012-5249, CVE-2012-5250, CVE-2012-5251,
CVE-2012-5253, CVE-2012-5254, CVE-2012-5255,
CVE-2012-5257, CVE-2012-5259, CVE-2012-5260,
CVE-2012-5262, CVE-2012-5264, CVE-2012-5265,
CVE-2012-5266, CVE-2012-5285, CVE-2012-5286,
CVE-2012-5287)

- Several unspecified issues exist that can lead to memory
corruption and arbitrary code execution. (CVE-2012-5252,
CVE-2012-5256, CVE-2012-5258, CVE-2012-5261,
CVE-2012-5263, CVE-2012-5267, CVE-2012-5268,
CVE-2012-5269, CVE-2012-5270, CVE-2012-5271,
CVE-2012-5272)

- An unspecified issue exists having unspecified impact.
(CVE-2012-5673)

See also :

http://www.adobe.com/support/security/bulletins/apsb12-22.html

Solution :

Upgrade to Adobe Flash Player version 10.3.183.29, 11.4.402.287 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true