Atlassian Confluence VelocityServlet Error Page XSS

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote web server hosts a web application that is affected by a
cross-site scripting vulnerability.

Description :

The remote server hosts an install of Atlassian Confluence that is
affected by a cross-site scripting vulnerability related to the
'ConfluenceVelocityServlet.class' and error pages.

User-supplied input in a URL is not validated properly before being
returned in an error page. This can result in an attacker-controlled
script running in the user's browser.

See also :

http://seclists.org/bugtraq/2012/Sep/68
http://www.nessus.org/u?7b8d76fc
https://jira.atlassian.com/browse/CONF-26366

Solution :

Apply the vendor patches or update to Confluence version 4.1.9 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 62356 ()

Bugtraq ID: 55509

CVE ID: