GLSA-201209-07 : International Components for Unicode: User-assisted execution of arbitrary code

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201209-07
(International Components for Unicode: User-assisted execution of arbitrary code)

An error in the _canonicalize() function in uloc.cpp could cause a
stack-based buffer overflow.

Impact :

A remote attacker could entice a user to open a specially crafted locale
representation using an application linked against ICU, possibly
resulting in execution of arbitrary code with the privileges of the
process or a Denial of Service condition.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201209-07.xml

Solution :

All ICU users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-libs/icu-49.1.1-r1'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 62288 ()

Bugtraq ID: 51006

CVE ID: CVE-2011-4599