Apache 2.2 < 2.2.23 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache 2.2 installed on the
remote host is earlier than 2.2.23. It is, therefore, potentially
affected by the following vulnerabilities:

- The utility 'apachectl' can receive a zero-length
directory name in the LD_LIBRARY_PATH via the 'envvars'
file. A local attacker with access to that utility
could exploit this to load a malicious Dynamic Shared
Object (DSO), leading to arbitrary code execution.
(CVE-2012-0883)

- An input validation error exists related to
'mod_negotiation', 'Multiviews' and untrusted uploads
that can allow cross-site scripting attacks.
(CVE-2012-2687)

Note that Nessus has not tested for these flaws but has instead relied
on the version in the server's banner.

See also :

http://www.apache.org/dist/httpd/CHANGES_2.2.23
http://httpd.apache.org/security/vulnerabilities_22.html

Solution :

Upgrade to Apache version 2.2.23 or later.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 62101 ()

Bugtraq ID: 53046
55131

CVE ID: CVE-2012-0883
CVE-2012-2687