Adobe AIR for Mac 3.x <= 3.3.0.3670 Multiple Vulnerabilities (APSB12-19)

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple security vulnerabilities.

Description :

According to its version, the instance of Adobe AIR on the remote
Mac OS X host is 3.3.0.3670 or earlier and is, therefore, reportedly
affected by multiple vulnerabilities :

- Multiple memory corruption vulnerabilities could lead to
code execution. (CVE-2012-4163, CVE-2012-4164,
CVE-2012-4165)

- An integer overflow vulnerability exists which could
lead to code execution. (CVE-2012-4167)

- A cross-domain information leak vulnerability exists.
(CVE-2012-4168)

- A crash can be caused by a logic error involving
multiple dialogs in Firefox. (CVE-2012-4171)

See also :

http://www.adobe.com/support/security/bulletins/apsb12-19.html

Solution :

Upgrade to Adobe AIR 3.4 (3.4.0.2540) or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 61625 ()

Bugtraq ID: 55365
56189
56191
56192
56196
56197
56199

CVE ID: CVE-2012-4163
CVE-2012-4164
CVE-2012-4165
CVE-2012-4167
CVE-2012-4168
CVE-2012-4171