GLSA-201208-06 : libgdata: Man-in-the-Middle attack

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201208-06
(libgdata: Man-in-the-Middle attack)

An error in the '_gdata_service_build_session()' function of
gdata-service.c prevents libgdata from properly validating certificates.

Impact :

A remote attacker could perform man-in-the-middle attacks to spoof
arbitrary SSL servers via a crafted certificate.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201208-06.xml

Solution :

All libgdata users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-libs/libgdata-0.8.1-r2'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 4.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 61545 ()

Bugtraq ID: 52504

CVE ID: CVE-2012-1177