Ubuntu 8.04 LTS / 10.04 LTS / 11.04 / 11.10 / 12.04 LTS : expat vulnerabilities (USN-1527-1)

Ubuntu Security Notice (C) 2012-2013 Canonical, Inc. / NASL script (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

It was discovered that Expat computed hash values without restricting
the ability to trigger hash collisions predictably. If a user or
application linked against Expat were tricked into opening a crafted
XML file, an attacker could cause a denial of service by consuming
excessive CPU resources. (CVE-2012-0876)

Tim Boddy discovered that Expat did not properly handle memory
reallocation when processing XML files. If a user or application
linked against Expat were tricked into opening a crafted XML file, an
attacker could cause a denial of service by consuming excessive memory
resources. This issue only affected Ubuntu 8.04 LTS, 10.04 LTS, 11.04
and 11.10. (CVE-2012-1148).

Solution :

Update the affected lib64expat1, libexpat1 and / or libexpat1-udeb
packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 61485 ()

Bugtraq ID: 52379

CVE ID: CVE-2012-0876
CVE-2012-1148