LibreOffice < 3.5.5 Multiple Heap-Based Buffer Overflows (Mac OS X)

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote host contains an application that is affected by multiple
buffer overflow vulnerabilities.

Description :

A version of LibreOffice prior to 3.5.5 is installed on the remote
Mac OS X host. It is, therefore, reportedly affected by multiple
heap-based buffer overflow vulnerabilities related to XML manifest
handling :

- An error exists related to handling the XML tag

- A boundary error exists when handling the duplication
of certain unspecified XML tags.

- An error exists in the base64 decoder related to XML
export actions.

See also :

Solution :

Upgrade to LibreOffice version 3.5.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 61433 ()

Bugtraq ID: 54769

CVE ID: CVE-2012-2665