Scientific Linux Security Update : libwpd on SL5.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

libwpd is a library for reading and converting Corel WordPerfect
Office documents.

A buffer overflow flaw was found in the way libwpd processed certain
Corel WordPerfect Office documents (.wpd files). An attacker could
provide a specially-crafted .wpd file that, when opened in an
application linked against libwpd, such as OpenOffice.org, would cause
the application to crash or, potentially, execute arbitrary code with
the privileges of the user running the application. (CVE-2012-2149)

All libwpd users are advised to upgrade to these updated packages,
which contain a backported patch to correct this issue. All running
applications that are linked against libwpd must be restarted for this
update to take effect.

See also :

http://www.nessus.org/u?3bbb9352

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 61355 ()

Bugtraq ID:

CVE ID: CVE-2012-2149