Scientific Linux Security Update : postgresql on SL6.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

It was discovered that a user could utilize the features of the
PL/Perl andaPL/Tcl languages to modify the behavior of a SECURITY
DEFINER functionacreated by a different user. If the PL/Perl or PL/Tcl
language was used toaimplement a SECURITY DEFINER function, an
authenticated database user couldause a PL/Perl or PL/Tcl script to
modify the behavior of that functionaduring subsequent calls in the
same session. This would result in theamodified or injected code also
being executed with the privileges of theauser who created the
SECURITY DEFINER function, possibly leading to privilege escalation.
(CVE-2010-3433)

These updated postgresql packages upgrade PostgreSQL to version 8.4.5.
Refer to the PostgreSQL Release Notes for a list of changes :

http://www.postgresql.org/docs/8.4/static/release.html

If the postgresql service is running, it will be automatically
restarted after installing this update.

See also :

http://www.nessus.org/u?0f784ca3
http://www.postgresql.org/docs/8.4/static/release.html

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.0
(CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 60906 ()

Bugtraq ID:

CVE ID: CVE-2010-3433