Scientific Linux Security Update : mikmod on SL3.x, SL4.x, SL5.x i386/x86_64

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

Multiple input validation flaws, resulting in buffer overflows, were
discovered in MikMod. Specially crafted music files in various formats
could, when played, cause an application using the MikMod library to
crash or, potentially, execute arbitrary code. (CVE-2009-3995,
CVE-2009-3996, CVE-2007-6720)

All running applications using the MikMod library must be restarted
for this update to take effect.

See also :

http://www.nessus.org/u?4c0dfd6d

Solution :

Update the affected mikmod and / or mikmod-devel packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 60860 ()

Bugtraq ID:

CVE ID: CVE-2007-6720
CVE-2009-3995
CVE-2009-3996