Scientific Linux Security Update : poppler on SL5.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.

Synopsis :

The remote Scientific Linux host is missing one or more security

Description :

CVE-2009-3608 xpdf/poppler: integer overflow in
ObjectStream::ObjectStream (oCERT-2009-016)

CVE-2009-3609 xpdf/poppler: ImageStream::ImageStream integer overflow

CVE-2009-3603 xpdf/poppler: SplashBitmap::SplashBitmap integer

Multiple integer overflow flaws were found in poppler. An attacker
could create a malicious PDF file that would cause applications that
use poppler (such as Evince) to crash or, potentially, execute
arbitrary code when opened. (CVE-2009-3603, CVE-2009-3608,

This update also corrects a regression introduced in the previous
poppler security update, RHSA-2009:0480, that prevented poppler from
rendering certain PDF documents correctly. (BZ#528147)

See also :

Solution :

Update the affected poppler, poppler-devel and / or poppler-utils

Risk factor :

High / CVSS Base Score : 9.3

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 60680 ()

Bugtraq ID:

CVE ID: CVE-2009-3603