Scientific Linux Security Update : yum-rhn-plugin on SL5.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing a security update.

Description :

It was discovered that yum-rhn-plugin did not verify the SSL
certificate for all communication with a Red Hat Network server. An
attacker able to redirect the network communication between a victim
and an RHN server could use this flaw to provide malicious repository
metadata. This metadata could be used to block the victim from
receiving specific security updates. (CVE-2008-3270)

See also :

http://www.nessus.org/u?25ac3d49

Solution :

Update the affected yum-rhn-plugin package.

Risk factor :

Low / CVSS Base Score : 2.6
(CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 60465 ()

Bugtraq ID:

CVE ID: CVE-2008-3270