Scientific Linux Security Update : perl on SL5.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

A flaw was found in Perl's regular expression engine. Specially
crafted input to a regular expression can cause Perl to improperly
allocate memory, possibly resulting in arbitrary code running with the
permissions of the user running Perl. (CVE-2007-5116)

See also :

http://www.nessus.org/u?2b628877

Solution :

Update the affected perl and / or perl-suidperl packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 60283 ()

Bugtraq ID:

CVE ID: CVE-2007-5116